• WhyEssEff [she/her]@hexbear.net
    link
    fedilink
    English
    arrow-up
    21
    ·
    edit-2
    18 hours ago

    the way I kinda know this is the product of C-Suite and not a low-level software engineer is that the syntax is mallocPlusAI and not aimalloc or gptmalloc or llmalloc.

    • WhyEssEff [she/her]@hexbear.net
      link
      fedilink
      English
      arrow-up
      20
      ·
      edit-2
      18 hours ago

      and it’s malloc, why are we doing this for things we’re ultimately just putting on the heap? overshoot a little–if you don’t know already, it’s not going to be perfect no matter what. if you’re going to be this annoying about memory (which is not a bad thing) learn rust dipshit. they made a whole language about it

      • WhyEssEff [she/her]@hexbear.net
        link
        fedilink
        English
        arrow-up
        9
        ·
        edit-2
        17 hours ago

        if they’re proposing it as a C stdlib-adjacent method (given they’re saying it should be an alternative to malloc [memory allocate]) it absolutely should be lowercase. plus is redundant because you just append the extra functionality to the name by concatenating it to the original name. mallocai [memory allocate ai] feels wrong, so ai should be first.

        if this method idea wasn’t an abomination in and of itself that’s how it would probably be named. it currently looks straight out of Java. and at that point why are we abbreviating malloc. why not go the distance and say largeLanguageModelQueryingMemoryAllocator